学习Vue.js遇到的问题

本文记录学习Vue.js遇到的错误


如何运行一个Vue项目

安装node.js

  • 选择对应版本,建议v6.9.1,下载完成,一路Next.
  • 安装完成之后,打开cmd,输入node -v,如果出现相应的版本号,则说明安装成功。
  • npm包管理器,是集成在node中的,cmd输入npm -v显示npm的版本信息,即安装成功。

安装cnpm

  • 在命令行中输入npm install -g cnpm --registry=http://registry.npm.taobao.org然后等待,安装完成如下图。

安装vue-cli脚手架构建工具

  • cnpm install -g vue-cli

新建第一个Vue项目

  • vue init webpack firstVue

运行

  • cd firstVue
  • npm run dev

常见错误

直接下载源码报错

  • error This is probably not a problem with npm. There is likely additional logging output above.
  • 解决:进去源码文件夹,输入npm installcnpm install,进行第三方包的下载安装

引用

标签: Vue,

更新于: 2019-05-21 12:48